Discussion:
[PATCH 1/2] atmodem/atutil: at_util_gprs_proto_to_pdp_type
Denis Kenzior
2018-10-22 20:04:10 UTC
Permalink
Hi Giacinto,
This function converts the ofono enum ofono_gprs_auth_method
into the value of the 3GPP 27.007 to pass to the AT command
---
drivers/atmodem/atutil.c | 16 ++++++++++++++++
drivers/atmodem/atutil.h | 3 +++
2 files changed, 19 insertions(+)
Your commit header does not match the patch contents or description.
You might want to slow down a bit.

Anyway, I renamed this to at_util_gprs_auth_method_to_auth_proto to
match 3GPP naming & the naming of the pdp_type conversion function in
the next patch. And fixed up the commit description / header.

Applied, thanks.

Regards,
-Denis
Denis Kenzior
2018-10-22 20:06:31 UTC
Permalink
Hi Giacinto,
The function at_util_get_cgdcont_command computes the AT+CGDCONT
string, as per 3GPP 27.007.
It uses a second function, at_util_gprs_proto_to_pdp_type,
that returns the pdp_type string for the command
---
drivers/atmodem/atutil.c | 27 +++++++++++++++++++++++++++
drivers/atmodem/atutil.h | 13 +++++++++++++
2 files changed, 40 insertions(+)
Applied, thanks.

Regards,
-Denis

Loading...